REVISIÓN DEL PROBLEMA: El servidor está ejecutando la versión de PHP, pero WordPress 5.1.6 3.2.1 5.2.4 requiere por lo menos.

Aviso para todos no es bien sabido que a instalar o hacer modernizaciónCPC a una versión más reciente de 3.2Es necesario que se instalará una nueva versión de 5.2.4.

Si el servidor es instalar una versión de PHP anterior a 5.2.4 instalar la versión WordPress 3.2.1aparecerá error / Mensaje "Su servidor está ejecutando la versión de PHP 5.1.6 Requiere WordPress 3.2.1 Pero 5.2.4 menos en".
El problema se puede resolver muy sencilla mediante la mejora de PHP, pero antes de hacerlo, algunas cosas deben ser consideradas. En primer lugar, actualizar PHP alojamiento es excluido de una participación. Por lo que puede hacer la actualización debe tener acceso de administrador en el servidor (servidor dedicado o VPS). En el segundo, antes de la actualización debe tener cuidado de documento y que nueva versión de PHP no dar Errores otros sitios alojados en ese servidor.

para OS es el más utilizado servidores web (Agreart y / WHM) Le mostrará cómo hacerlo actualización de PHP en CentOS 5.2.10.x 5 32 bits.

Actualizar a PHP 5.1.x 5.2.x en 5 bits CentOS 32.x

1. Comprobar los paquetes / módulos están instalados PHP (ex. Php-mcrypt), además de paquetes estándar. Si los hay, serán eliminados o actuzlizate.

Compruebe los paquetes instalados:

rpm -qa | php grep

old_php_version

2. Añadir nuevos archivos necesario modernizaciónversión de PHP acervo.

nano / etc / yum.repos.d / CentOS-Testing.repo

En el archivo recién creado (CentOS-Testing.repo) Añadirá las líneas de abajo (copiar / pegar):

[C5-testing]
name = 5 CentOS-Testing
baseurl = http: //dev.centos.org/centos/$releasever/testing/$basearch/
enabled = 1
gpgcheck = 1
gpgkey = http: //dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X para guardar el archivo CentOS-Testing.repo.

3. actualización de PHP a través de yum:

yum update

4. reanudar / httpd :

servicio httpd restart

Después de la versión httpd restart y comprobar los paquetes instalados:

new_php_version

Compruebe si hay errores módulos / paquetes:

php -v

Actualizar PHP / 32 bits CentOS (i386).

REVISIÓN DEL PROBLEMA: El servidor está ejecutando la versión de PHP, pero WordPress 5.1.6 3.2.1 5.2.4 requiere por lo menos.

Sobre el Autor

stealth LP

Fundador y editor Opciones de invisibilidadEn fecha 2006.
La experiencia en los sistemas operativos Linux (especialmente CentOS), Mac OS X, Windows XP> Windows 10 y WordPress (CMS).

Deja un comentario

Este sitio usa Akismet para reducir el correo no deseado. Descubra cómo se procesan los datos de sus comentarios.